Welcome, Guest. [ Log In ]
Question   I get an error with File::Spec when using Movable Type!
Search KBase


Top in this Area:
1. I get an error with File::Spec when using Movable Type!

 
I get an error with File::Spec when using Movable Type!
First, a VERY useful thread about this at movabletype's message board.

Movable Type requires a pretty new version of the perl module "File::Spec" to run. Although most of our machines have it, some do not. You can download the newest version of File::Spec and install it in your home directory though, and then no matter what version is on our server, your Movable Type installation will continue to work!

Go to http://www.cpan.org/modules/by-module/File/ and get the file that is something like File-Spec-0.82.tar.gz.

Download this to your home directory and then untar it. Copy the perl files into a directory in your home directory and then add the appropriate "use lib" command to your MT installation!

If these instructions are a bit over your head, please try asking people at our discussion board or the Movable Type one for more help!

Last updated: Jun 10, 2003.

Official Reply (2004-05-10 11:55:34 )
this isn't strictly about the file::spec issue, but http://www.wombatnation.com/misc/installMTDreamHost.html is an invaluable guide to installing MT at DH. fyi.